
 
 
                                    SeaTTY  

 

 

 

 

 

 

 
Questo programma e’ adatto per ricevere bollettini meteo, avvisi alla navigazione e carte meteo 

trasmesse nei modi RTTY, NAVTEX, e HF-FAX (WEFAX), nelle gamme delle onde lunghe e onde corte.  

 

Il programma puo’ inoltre decodificare i messaggi nel modo GMDSS DSC (Digital selective-calling 

system) in HF eVHF. 

 

Il software e’ in grado di salvare in  modo automatico i messaggi vocali NOAA Weather Radio SAME e 

loro intestazioni digitali. 

 

Per usare questo programma non e’ richiesto nessun hardware aggiuntivo, e’ necessario solo un computer 

con scheda audio. 

 

Il minimo requisito richiesto inerente alla velocita’ del calcolatore e’ almeno un Pentium 100. 
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 Come connettere la scheda audio al ricevitore 

 

L’uscita audio del ricevitore deve essere connessa all’ingresso linea o microfono della scheda audio. 

 

Se la scheda audio e’ prevista d’ingresso stereo allora connettere insieme il canale drstro e quello sinistro. 

Il ricevitore deve essere sintonizzato in modo SSB (LSB o USB), per decodificare i modi RTTY,NAVTEX , 

GMDSS HF/VHF e FAX- HF. 
 

E’ MOLTO importante evitare il sovracarico dell’ingresso della sceda audio. 

 

Se necessario usare un attenuatore esterno per ridurre l’uscita audio del ricevitore, se l’ingresso della scheda 

audio e’ sovracaricato allora non si potranno eliminare le distorsioni dai controlloi del sistema operativo del 

computer. 

 

La scheda audio dovrebbe supportare in mono “16 bit e 11025 Hz”. 

 

Per scegliere la sorgente del segnale (line-in o microfono) e il livello di segnale seguire questi step: 

 

Doppio click sull’icona Volume visualizzata nel menu’ in basso a destar del monitor, selezionare: 

Opzioni => Proprieta’ => Registrazione => ok =>… a questo punto si puo’ selezionare l’ingresso del 

segnale e settarne il livello. 

 

Fare attenzione, nelle opzioni di “Volume” di scegliere REGISTRAZIONE e non 

RIPRODUZIONE. 

 
Una volta selezionato l’ingresso del segnale controlla di non sovraccaricarlo con livelli troppo elevati. 

Se il computer in vostra dotazione dispone di piu’ di una scheda audio potra selezionare quella di tuo 

interesse con questo percorso: 

 

 

Con il programma aperto seleziona dal menu’ Setup => Interface => Soundcard Number . 

 

 

 

 

 

 

 

 



                    Panoramica del programma  

 

La finestra di lavoro del programma e’ divisa in piu’ aree che possono essere personalizzate dall’utente 

tramite la funzione di definizione dei bordi di Windows. 

 

 

 

 

 

 

Nella finestra superiore sono mostrati il segnale corrente (segnale blue) e i picchi relativi (segnale verde). 

Le due linee verticali rosse,  indicano le frequenze di lavoro del filtro di decodifica. 

 

Nella modalita’ FAX determinano le frequenze di bianco/nero. 

 

E’ possibile variare la frequenza del segnale ricevuto cliccando in mezzo alle due verticali rosse, ma questo 

e’subordinato al modo di ricezione. 

 

Nella finestra posta piu’ in basso si potra’ vedere l’oscillogramma del segnale decodificato. 

Questa finetra puo’ essere nascosta  con l’opzione Setup =>View => Show oscillogram window . 

 

L’opzione Setup => Logarithmic => Spectrogram scale oppure (Alt-Z) consente di commutare da 

logaritmico a lineare la scala dello spettrogramma del segnale ricevuto. 



Analogamente l’opzione Setup => Logarithmic => Spectrogram scale oppure (CTRL-Z) consente di 

eseguire la stessa funzione ma riferita all’oscillogramma del segnale ricevuto. 

 

La scala logaritmica e’ consigliata poiche ‘ la scala lineare richiede al computer piu’ risorse. 

 

L’icona SQL permette d’inserire o meno lo squelch e il suo livello puo’ essere impostato modificando il 

valore numerico nella casella alla sua sinistra. 

 

Quando lo squelch e’ inserito, nella finestra dello spettrogramma, comparira’ una linea rossa orizzontale che 

ne indichera’ la soglia. 

 

L’icona AFC, (auto frequency control), consente di avvicinare il piu’ possibile le due linee rosse ai picchi 

del segnale, le caselle numeriche alla sinitra di questa icona, se opportunamente settate, consentono una 

veloce ricerca dei picchi di segnale, la prima casella rappresenta la deviazione locale di frequenza mentre  

La seconda indica la deviazione globale di frequenza in Hertz. 

 

La variazione di questi valori incide sulle due linne rosse di lunghezza inferiore nella finestra dello 

spettrogramma. 

 

Nel modo HF-FAX questo comabdo lavoro solo con i segnali di sincronismo che sono trasmessi solitamente 

prima dell’immagine vera e propria. 

 

Questo comando NON lavora quando sono selezionati i modi NWR-SAME e GMDSS DSC VHF dal 

momento che le frequenze sono definite da protocolli specifici. 

 

L’icona Reverse/Normal  definisce la polarita’ di decodifica. 

 

Per le stazioni meteo dovrebbe essere settato in Normal con ricezione USB oppure in Reverse con ricezione 

LSB nei modi RTTY, NAVTEX and HF-FAX. 

 

Tenere presente che qualche stazione radioamatoriale e commerciale che emettono in RTTY usano  

porita’ opposte e in modo NWR-SAME questa opzione e’ ignorata. 

 

L’icona Mode permette di selezionare la ricezione nei modi RTTY, NAVTEX, HF-FAX, NWR-SAME, 

GMDSS DSC - HF, GMDSS DSC - VHF. 

 

Nel modo HF-FAX vedere capitolo a parte. 

 

In modo RTTY si possono selezionare i comandi di Speed e di Shift dai rispettivi menu’ 

 

Le stazioni metereologi che usano come speed 50Baud e uno shift di 85 Hz quando in onde lunghe  e uno 

shift di 450 Hz quando in onde corte. 

 

I radioamatori usano 45 Baud come speed e 170 Hz comr shift, le stazioni commerciali usano 50 Baud  e 170 

Hz di shift. 

 

Il menu’ di shift consente di selezionare 800 o 300 Hz, il primo e’ considerato la deviazione standard, il 

secondo e’ considerato stretto, (narrow), ed e’ usato in modalita HF-FAX. 

 

La deviazione narrow e’ usata nella banda delle onde lunghe. 

 

Dal  menu’ Setup =>Text => Fast sinchronization in NAVTEX si definisce la modalita’ di sicronizzazione 

quando si e’ in modalita’ NAVTEX. 

 

Quando questa opzione e’ selezionata allora il programma sara ‘ in grado di eseguire una sincronizzazione 

molto veloce con il segnale ricevuto, anche se in qualche caso si possono aver degli errori. 



L’icona On Top quando selezionata pone la finestra del programma in primo piano. 

Il testo ricevuto e’ mostrato in una seconda finestra. 

 

Dal menu’ File => Clear Buffer si puo’ pulire la finestra e se Setup => Text => Clear RX Window Once 

a day e’ selezionato allora si avra’ la pulizia automatica all’inizio di ogni giorno. 

 

Il programma scrive di quanto ricevuto in una cartella nominata RAW_LOGS. 

 

Il nome del file, nel log  e’ espresso con la data di ricezione, per esempio: 01-10-08.TXT significa 08 

Ottobre 2001. 

 

Se l’opzione Setup->Text->Put time-stamps in raw logs e’ selezionata SeaTTY scrivera’  l’ora all’inizio di 

ogni  file nel log. 

 

Tutti i messaggi meteo e le intestazioni SAME iniziano con una sequenza di  ZCZC e terminano con una 

sequenza di NNNN. 

 

SeaTTY rileva questi caratteri e li scrive nella cartella messaggi e il nome del file e’ espresso con 

data/ora/numero incrementale. 

 

Quattro dopo ZCZC in modalita’ NAVTEX indicano lo Station ID, in modo similare la stessa cosa avviene 

in modalita’ RTTY, se lo Station ID e’ rilevato nel messaggio questo sara’ incluso nel nome del file. 

 

Per esmpio: 011121-225525-KA56.TXT e’ un messaggio con Station ID KA56 iniziato alle 22.55.25 del 

21 Novembre 2001. 

 

Per ridurre il rischio di perdita dei messaggi a causa del QRM di fondo SeaTTY inizia a scrivere il 

messaggio solo se almeno tre caratteri di ZCZC sono ricevuti. 

 

In  modalita’ NWR-SAME il programma elabora un messaggio vocale in formato wave  e le intestazioni in 
formato txt, per sempio: 011121-225525.WAV e 011121-225525.TXT. 

 

L’opzione Setup / Other / Ignore EOM in SAME e’ usata per ricevere il messaggi vocali dai sistemi i quali 

trasmettono la sequenza End Of Message prima del messaggio. 

 

In questo caso la misura di un file salvato wave e’ definito da Setup / Other / EOM timeout in SAME, 

minutesSetup . 

 

Il filtro di Station ID puo’ essere abilitato dalla pagina Setup/Filters. 

 

Se l’opzione Use ID filter in RTTY e’ selezionata saranno salvati i messaggi che avranno un ID appropriato. 

 

Analogamente se l’opzione Use ID filter in NAVTEX e’ selezionata saranno salvati i messaggi che avranno 

un ID appropriato nel modo NAVTEX. 

 

La lista dei filtri include 4-sybol mask, che consistono di: lettere “?”, e "#” simboli. 

 “?” significa qualsiasi lettera, "# significa qualsiasi simbolo. 

 

Il comando Add aggiunge un filtro mentre il comando Delete cancella il filtro dalla lista. 

 

 



 
 

 

Se l’opzioneSetup->Filters->Don't save SYNOP messages e’ selezionata SeaTTY non salva I messaggi 

SYNOP, anche perche’ questi messaggi non sono leggibili. 

 

L’opzione Setup->Text->Use UTC time definisce l’uso dell’orairo locale oppure UTC. 

 

In HF-FAX mode il comando Start consente di ricevere il messaggio manualmente,il comando Stop consente 

di fermarlo. 

 

Le immaggini ricevute in  modo HF-FAX sono salvate nella cartella "Messages", il file sara’ nominato con 

questo formato 030710-153027.PNG che significa salvato il 10 Luglio 2003 alle ore 15:30:30. 

 

Nella finestra in basso a sinistra sono mostrati dei file testo oppure file d’ immagini delle ricezioni effettuate. 

 

Per aprirli  fare doppio click col pulsante sinistro del mouse oppure uno solo con il pulsante destro. 

 

Nel caso d’immagini di fax si possono usare i pulsanti M- e M+ per canbiare la scala d’ingrandimento. 

 

L’opzione  Unshift On Space puo’ essere attivata tramite Setup -> Text -> Unshift on space, quando 

questa opzione e’ selezionata" viene attivata la ricezione in modalita’ lettere anziche’ simboli dopo aver 

ricevuto il segnale di spazio o cambio riga. 
 

L’opzione Setup->Text->RTTY alphabet->English charset, Setup->Text->RTTY alphabet->Russian 

charset, Setup->Text->RTTY alphabet->Swedish Charset and "Setup->Text->RTTY alphabet                  
->English/Russian Extended charset seleziona l’alfabeto che si vuole usare. 

 

L’opzione Setup->Text->Extended Baudot se selezionata commuta sulla tabella piu’ estesa, (con caratteri 

maiuscoli e minuscoli). 

 

Il comando File->Open Wave Capture File permette di salvare in formato “wave” quanto ricevuto dalla 

scheda audio. 

 

File->Close Wave Capture File, permette di chiudere l’operazione di “save” del file. 

 



 

 

 

 

 

 

Alt-V puo’ essere usato per aprire chiudere l’operazione di salvataggio del file. 

 

Tenere presente  che un minuto di registrazione occupa circa 1Mb di spazio su HD. 

 

SeaTTY  e’ in grado di decodificare un segnale da un file in formato WAVE. 

 

Il file interessato puo’ essere selezionato da File->Decode From File.  

 

Il file deve essere Windows PCM file, senza compressioni. 

 

Il campionamento dovrebbe essere di 11025, 22050 o di 44100 HZ. 

 

I parametri consigliati sono: audio mono, 16 bit, 11025 Hz. 

 

Le caratteristiche del video possono essere cambiate da Setup->Fonts & colors. 

 

Il metodo per correggere la variazione di campionamento della scheda audio rispetto al valore preimpostato 

di 11025 Hz puo’ essere eseguita con la correzione dell’inclinazione dell’immagine in modalita’ HF-FAX, 

in questo caso vedere il menu’ di Setup => FAX. 

 

Per i dettagli vedere qui. 

 

Il numero mostrato nella casella UpB indica dei segnali ricevuti ma non registrati, se questo valore supera il 

valore di 10 verra’, quasi sicuramente compromessa la velocita del computer. 

 

In questo caso occcorre chiudere tutte le applicazioni non necessarie. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

                                                             HF-FAX mode 

 

 

 

In moodalita’ HF-FAX si aprira’ questa finestra. 

 

 

 

 
 

 

 

Il comando Auto S abilita la funzione di auto start/autostop dell’immagine fax, questo dipende dal tono di 

APT, che quando ricevuto, abilita SeaTTy alla ricezione in modo automatico. 

 

Quando il programma ricevera’ il tono di stop l’immagine sara’ salvata in modo automatico. 

 

La soglia dei comandi di auto start/autistop puo’ essere regolata da Setup/FAX. 

 

La sequenza di start e’ espressa con dei toni di biaco/nero alla frequenza di 300 o 675 Hz. 

 

Il segnale di stop immagine ha la frequenza di 450 Hz. 

 

I comandi di Start/Stop danno l’inizio e la fine del messaggio fax in modo manuale, per salvare l’immagine 

questa deve essere fermata. 

 

 

Questo comando, ->||<-,  permette di centrare l’immagine ricevuta in senso orrizontale. 

 

Questa funzione puo’ essere eseguita anche durante la ricezione. 



 
 

 

Questo comando, <-/|\->, permette di correggere l’inclinazione di cui potrebbe essere affetta l’immagine che 

stiamo ricevendo. 

 

 
 

Quando abbiamo a disposizione un’immagine ricevuta selezionare Stop e selezionare il comando <-/|\->. 
 

A questo punto individuare nell’immagine una linea che dovrebbe essere verticale. 

 

Con il tasto sinistro del mouse fare click nella parte alta della linea e un altro click nella parte bassa. 

 

Una finestra comparira’ comunicando il nuovo valore di campionamento della scheda audio. 

 

Premere OK per registrare il nuovo valore e l’immagine si raddrizzera’. 

 

LPM e IOC sono parametri che SeaTTY prova a riconoscere in automatico, se non fosse possible meglio 

introdurre manualmente i valori da programma. 



 

 

 

 

 

 

 

 

 

 

 

                               Licenza d’uso  
 

 

 

 

 

 

 

 

 

 

Potete distribuire copie del programma osservando le due condizioni seguenti: 

   

 

    1. Se lo fate gratuitamente.  

    2. Se distribuite l’archivio originale senza modifiche. 

 

 
Il programma viene distribuito come “Shareware”. Puoi usarlo in modo gratuito per 30 giornil,se desideri 

continua ad usare questo software dopo il periodo di valutazione allora  devi fare il pagamento della 

registrazione all’autore. La copia non registrata di CwGet ha alcune caratteristiche disabilitate. 

 

Per effettuare il pagamento di, ($45 or 35 Euro), lanciate  CwGet e selezionate il menu 

"Help->Register!". Oppure, aperto il vostro browser Internet, andate ad uno dei seguenti URL: 

 

 
https://secure.avangate.com/order/checkout.php?PRODS=1541504&QTY=1 
  

 
 https://www.regnow.com/softsell/nph-softsell.cgi?item=3043-3 

 

 

Il codice di registrazione verra mandato via e-mail, nel caso questo non pervenisse allora 

contattare http://www.dxsoft.com/support/ per ottenere il codice registrazione. 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

                 
                                    Links utili 
 
 
 
 
 
In Internet potrete trovare, tramite questi link, utili informazioni su come usare correttamente SeaTTY.  
  
NWR-SAME description - http://www.weather.gov/nwr/nwrsame.htm 

  

GMDSS DSC description - http://www.navcen.uscg.gov/?pageName=mtDsc 

  

http://hffax.de/ 

  

http://www.dxradio.co.uk/ 

  

Soundcard interfaces review - http://www.qsl.net/wm2u/interface.html 

  

NavtMsgs - http://home.planet.nl/~hagem358/Navt_GB.htm   
 
Controllare anche software gratuiti che possono essere condivisi con SeaTTY.... 
 

 

 

 


